lkml.org 
[lkml]   [2016]   [Dec]   [16]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH 1/4] mm: add new mmgrab() helper
On Fri 16-12-16 11:20:40, Vegard Nossum wrote:
> On 12/16/2016 11:19 AM, Kirill A. Shutemov wrote:
> > On Fri, Dec 16, 2016 at 10:56:24AM +0100, Peter Zijlstra wrote:
> > > But I must say mmget() vs mmgrab() is a wee bit confusing.
> >
> > mm_count vs mm_users is not very clear too. :)
> >
>
> I was about to say, I'm not sure it's much better than mmput() vs
> mmdrop() or mm_users vs mm_count either, although the way I rationalised
> it was the 3 vs 4 letters:
>
> mmget() -- mmgrab()
> mmput() -- mmdrop()
> ^^^ 3 ^^^^ 4

get -> put
grab -> drop

makes sense to me... No idea about a much more clear name.
--
Michal Hocko
SUSE Labs

\
 
 \ /
  Last update: 2016-12-16 11:43    [W:0.054 / U:2.012 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site