lkml.org 
[lkml]   [2016]   [Nov]   [29]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Subject[mm PATCH 0/3] Page fragment updates
From
Date
This patch series takes care of a few cleanups for the page fragments API.

First we do some renames so that things are much more consistent. First we
move the page_frag_ portion of the name to the front of the functions
names. Secondly we split out the cache specific functions from the other
page fragment functions by adding the word "cache" to the name.

Second I did some minor clean-up on the function calls so that they are
more inline with the existing __free_pages calls in terms of how they
operate.

Finally I added a bit of documentation that will hopefully help to explain
some of this. I plan to revisit this later as we get things more ironed
out in the near future with the changes planned for the DMA setup to
support eXpress Data Path.

---

Alexander Duyck (3):
mm: Rename __alloc_page_frag to page_frag_alloc and __free_page_frag to page_frag_free
mm: Rename __page_frag functions to __page_frag_cache, drop order from drain
mm: Add documentation for page fragment APIs


Documentation/vm/page_frags | 42 +++++++++++++++++++++++++++++
drivers/net/ethernet/intel/igb/igb_main.c | 6 ++--
include/linux/gfp.h | 9 +++---
include/linux/skbuff.h | 2 +
mm/page_alloc.c | 33 +++++++++++++----------
net/core/skbuff.c | 8 +++---
6 files changed, 73 insertions(+), 27 deletions(-)
create mode 100644 Documentation/vm/page_frags

--

\
 
 \ /
  Last update: 2016-11-29 19:23    [W:0.081 / U:0.856 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site