lkml.org 
[lkml]   [2016]   [Nov]   [25]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
SubjectRe: [PATCH 2/6] KVM: x86: decouple irqchip_in_kernel() and pic_irqchip()
From
Date


On 25/11/2016 18:11, Radim Krčmář wrote:
> 2016-11-25 03:59-0500, Paolo Bonzini:
>> ----- Original Message -----
>>> From: "Radim Krčmář" <rkrcmar@redhat.com>
>>> To: "Paolo Bonzini" <pbonzini@redhat.com>
>>> Cc: linux-kernel@vger.kernel.org, kvm@vger.kernel.org
>>> Sent: Thursday, November 24, 2016 6:21:04 PM
>>> Subject: Re: [PATCH 2/6] KVM: x86: decouple irqchip_in_kernel() and pic_irqchip()
>>>
>>> 2016-11-24 11:55-0500, Paolo Bonzini:
>>>>> irqchip_in_kernel() tried to save a bit by reusing pic_irqchip(), but it
>>>>> just complicated the code.
>>>>> Add kvm->arch.irqchip_kvm that matches kvm->arch.irqchip_split.
>>>>> (Turning them into an exclusive type would be nicer.)
>>>>
>>>> Then do it. ;)
>>>
>>> It is hard to name! :)
>>>
>>> I would squash something like this if the names were ok:
>>>
>>> diff --git a/arch/x86/include/asm/kvm_host.h
>>> b/arch/x86/include/asm/kvm_host.h
>>> index 929228ec2839..726235f0e3f3 100644
>>> --- a/arch/x86/include/asm/kvm_host.h
>>> +++ b/arch/x86/include/asm/kvm_host.h
>>> @@ -706,6 +706,12 @@ struct kvm_hv {
>>> HV_REFERENCE_TSC_PAGE tsc_ref;
>>> };
>>>
>>> +enum kvm_kernel_irqchip {
>>
>> kvm_kernel_irqchip_mode?
>
> If we append the mode, what about just "kvm_irqchip_mode"?
>
> irqchip_in_kernel() tells which one is in the kernel.
>
>>> + KVM_IRQCHIP_NONE,
>>> + KVM_IRQCHIP_KVM, /* created in KVM_CREATE_IRQCHIP */
>>> + KVM_IRQCHIP_SPLIT, /* created in KVM_CAP_SPLIT_IRQCHIP */
>>
>> Since you pretty much asked to nitpick,
>
> I am always interested in nitpicks!
>
>> KVM_IRQCHIP_KERNEL would
>> match irqchip_in_kernel better.
>
> Matching the enum name prefix would be nice, so I'd rename it to
> enum kvm_irqchip_kernel_mode then. I'd keep them this way if we go with
> enum kvm_irqchip_mode.

kvm_irqchip_mode is best I think (NONE/KERNEL/SPLIT).

Paolo

>> Also, s/in/with/? :)
>
> Ok.
>
>>> +};
>>> +
>>> struct kvm_arch {
>>> unsigned int n_used_mmu_pages;
>>> unsigned int n_requested_mmu_pages;
>>> @@ -778,8 +784,7 @@ struct kvm_arch {
>>>
>>> u64 disabled_quirks;
>>>
>>> - bool irqchip_kvm;
>>> - bool irqchip_split;
>>> + enum kvm_kernel_irqchip irqchip;
>>
>> irqchip_mode?
>
> Yes, thanks.
>

\
 
 \ /
  Last update: 2016-11-25 18:23    [W:0.983 / U:0.064 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site