lkml.org 
[lkml]   [2016]   [Nov]   [15]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
SubjectRe: [PATCH 00/34] perf clang: Builtin clang and perfhook support
From
Date


On 2016/11/15 12:57, Alexei Starovoitov wrote:
> On Mon, Nov 14, 2016 at 8:05 PM, Wang Nan <wangnan0@huawei.com> wrote:
>> This is version 2 of perf builtin clang patch series. Compare to v1,
>> add an exciting feature: jit compiling perf hook functions. This
>> features allows script writer report result through BPF map in a
>> customized way.
> looks great.
>
>> SEC("perfhook:record_start")
>> void record_start(void *ctx)
>> {
>> int perf_pid = getpid(), key = G_perf_pid;
>> printf("Start count, perfpid=%d\n", perf_pid);
>> jit_helper__map_update_elem(ctx, &GVALS, &key, &perf_pid, 0);
> the name, I think, is too verbose.
> Why not to keep them as bpf_map_update_elem
> even for user space programs?

I can make it shorter by give it a better name or use a wrapper like

BPF_MAP(update_elem)

but the only thing I can't do is to make perfhook and in-kernel script
use a uniform name for these bpf_map functions, because
bpf_map_update_elem is already defined:

"static long (*bpf_map_update_elem)(void *, void *, void *, unsigned
long) = (void *)2;\n"


>> SEC("perfhook:record_end")
>> void record_end(void *ctx)
>> {
>> u64 key = -1, value;
>> while (!jit_helper__map_get_next_key(ctx, &syscall_counter, &key, &key)) {
>> jit_helper__map_lookup_elem(ctx, &syscall_counter, &key, &value);
>> printf("syscall %ld\tcount: %ld\n", (long)key, (long)value);
> this loop will be less verbose as well.


\
 
 \ /
  Last update: 2016-11-15 06:05    [W:0.030 / U:0.560 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site