lkml.org 
[lkml]   [2016]   [Nov]   [15]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH v11 2/3] drm/fence: add fence timeline to drm_crtc
On Tue, Nov 15, 2016 at 05:42:35PM +0900, Gustavo Padovan wrote:
> 2016-11-15 Chris Wilson <chris@chris-wilson.co.uk>:
>
> > On Tue, Nov 15, 2016 at 10:57:35AM +0900, Gustavo Padovan wrote:
> > > diff --git a/include/drm/drm_crtc.h b/include/drm/drm_crtc.h
> > > index 11780a9..0870de1 100644
> > > --- a/include/drm/drm_crtc.h
> > > +++ b/include/drm/drm_crtc.h
> > > @@ -32,6 +32,8 @@
> > > #include <linux/fb.h>
> > > #include <linux/hdmi.h>
> > > #include <linux/media-bus-format.h>
> > > +#include <linux/srcu.h>
> > > +#include <linux/dma-fence.h>
> > > #include <uapi/drm/drm_mode.h>
> > > #include <uapi/drm/drm_fourcc.h>
> > > #include <drm/drm_modeset_lock.h>
> > > @@ -739,9 +741,52 @@ struct drm_crtc {
> > > */
> > > struct drm_crtc_crc crc;
> > > #endif
> > > +
> > > + /**
> > > + * @fence_context:
> > > + *
> > > + * timeline context used for fence operations.
> > > + */
> > > + unsigned int fence_context;
> > > +
> > > + /**
> > > + * @fence_lock:
> > > + *
> > > + * spinlock to protect the fences in the fence_context.
> > > + */
> > > +
> > > + spinlock_t fence_lock;
> > > + /**
> > > + * @fence_seqno:
> > > + *
> > > + * Seqno variable used as monotonic counter for the fences
> > > + * created on the CRTC's timeline.
> > > + */
> > > + unsigned long fence_seqno;
> > > +
> > > + /**
> > > + * @timeline_name:
> > > + *
> > > + * The name of the CRTC's fence timeline.
> > > + */
> > > + char timeline_name[32];
> > > };
> > >
> > > /**
> > > + * dma_crtc_fence_ops - fence ops for the drm_crtc timeline
> > > + *
> > > + * It contains the dma_fence_ops that should be called by the dma_fence
> > > + * code. CRTC core should use this ops when initializing fences.
> > > + */
> > > +extern const struct dma_fence_ops drm_crtc_fence_ops;
> > > +
> > > +static inline struct drm_crtc *fence_to_crtc(struct dma_fence *fence)
> > > +{
> > > + BUG_ON(fence->ops != &drm_crtc_fence_ops);
> > > + return container_of(fence->lock, struct drm_crtc, fence_lock);
> > > +}
> >
> > If you are planning to export this for use by drivers, you are missing
> > the EXPORT_SYMBOL(drm_crtc_fence_ops).
>
> Drivers should not be using this, at least for now.

You've put into a central header, with kerneldoc on the ops, just inviting
people to use it...
-Chris

--
Chris Wilson, Intel Open Source Technology Centre

\
 
 \ /
  Last update: 2016-11-15 09:56    [W:1.202 / U:0.104 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site