Messages in this thread |  | | Date | Wed, 26 Oct 2016 19:33:07 +0200 (CEST) | | From | Thomas Gleixner <> | | Subject | Re: [PATCH v5 12/18] x86/intel_rdt: Add "info" files to resctrl file system |
| |
On Wed, 26 Oct 2016, Luck, Tony wrote: > >> + .mode = 0444, > >> + .kf_ops = &rdtgroup_kf_single_ops, > >> + .seq_show = rdt_num_closid_show, > >> + }, > >> + { > >> + .name = "cbm_val", > > > > cbm_val? Is that a value? No, it's the valid bitmask which you can set. So > > cmb_mask or something else which is unambiguous is what you want here. > > > > This is a user space interface and we really must make it as intuitive as > > possible. > > It's a bit mask for cache resources. But this interface will also control resources that are not caches, so I'd like to avoid "cbm" in the name. Perhaps "max_val"? >
max_val is misleading if it's always a bit mask. 'bitmask' might not be the worst choice then.
Thanks,
tglx
|  |