lkml.org 
[lkml]   [2016]   [Oct]   [2]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH] staging: sm750fb: rename macro roundedDiv to rounded_div in ddk750_chip.c
On Sun, Oct 02, 2016 at 08:48:32AM +0300, Moshe Green wrote:
> Rename CamelCased macro roundedDiv to rounded_div.
>
> This issue was found by checkpatch.pl
>
> Signed-off-by: Moshe Green <mgmoshes@gmail.com>
> ---
> drivers/staging/sm750fb/ddk750_chip.c | 6 +++---
> 1 file changed, 3 insertions(+), 3 deletions(-)
>
> diff --git a/drivers/staging/sm750fb/ddk750_chip.c b/drivers/staging/sm750fb/ddk750_chip.c
> index 3a0afe1..e4efe91 100644
> --- a/drivers/staging/sm750fb/ddk750_chip.c
> +++ b/drivers/staging/sm750fb/ddk750_chip.c
> @@ -7,7 +7,7 @@
> #include "ddk750_power.h"
>
> /* n / d + 1 / 2 = (2n + d) / 2d */
> -#define roundedDiv(num, denom) ((2 * (num) + (denom)) / (2 * (denom)))
> +#define rounded_div(num, denom) ((2 * (num) + (denom)) / (2 * (denom)))

Shouldn't you use the in-kernel function for this instead?

\
 
 \ /
  Last update: 2016-10-02 11:47    [W:0.076 / U:0.084 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site