lkml.org 
[lkml]   [2016]   [Oct]   [17]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
    Patch in this message
    /
    From
    Subject[Patch v5 03/12] irqchip: xilinx: Rename get_irq to xintc_get_irq
    Date
    Now that the driver is generic and used by multiple archs,
    get_irq is too generic.

    Rename get_irq to xintc_get_irq to avoid any conflicts

    Signed-off-by: Zubair Lutfullah Kakakhel <Zubair.Kakakhel@imgtec.com>

    ---
    V4 -> V5
    Rebased to v4.9-rc1
    Use __func__ in pr_err

    V3 -> V4
    New patch.
    ---
    arch/microblaze/include/asm/irq.h | 2 +-
    arch/microblaze/kernel/irq.c | 4 ++--
    drivers/irqchip/irq-xilinx-intc.c | 4 ++--
    3 files changed, 5 insertions(+), 5 deletions(-)

    diff --git a/arch/microblaze/include/asm/irq.h b/arch/microblaze/include/asm/irq.h
    index bab3b13..d785def 100644
    --- a/arch/microblaze/include/asm/irq.h
    +++ b/arch/microblaze/include/asm/irq.h
    @@ -16,6 +16,6 @@
    extern void do_IRQ(struct pt_regs *regs);

    /* should be defined in each interrupt controller driver */
    -extern unsigned int get_irq(void);
    +extern unsigned int xintc_get_irq(void);

    #endif /* _ASM_MICROBLAZE_IRQ_H */
    diff --git a/arch/microblaze/kernel/irq.c b/arch/microblaze/kernel/irq.c
    index 11e24de..903dad8 100644
    --- a/arch/microblaze/kernel/irq.c
    +++ b/arch/microblaze/kernel/irq.c
    @@ -29,12 +29,12 @@ void __irq_entry do_IRQ(struct pt_regs *regs)
    trace_hardirqs_off();

    irq_enter();
    - irq = get_irq();
    + irq = xintc_get_irq();
    next_irq:
    BUG_ON(!irq);
    generic_handle_irq(irq);

    - irq = get_irq();
    + irq = xintc_get_irq();
    if (irq != -1U) {
    pr_debug("next irq: %d\n", irq);
    ++concurrent_irq;
    diff --git a/drivers/irqchip/irq-xilinx-intc.c b/drivers/irqchip/irq-xilinx-intc.c
    index fe533e1..45e5154 100644
    --- a/drivers/irqchip/irq-xilinx-intc.c
    +++ b/drivers/irqchip/irq-xilinx-intc.c
    @@ -119,7 +119,7 @@ static void intc_mask_ack(struct irq_data *d)

    static struct irq_domain *root_domain;

    -unsigned int get_irq(void)
    +unsigned int xintc_get_irq(void)
    {
    unsigned int hwirq, irq = -1;

    @@ -127,7 +127,7 @@ unsigned int get_irq(void)
    if (hwirq != -1U)
    irq = irq_find_mapping(root_domain, hwirq);

    - pr_debug("get_irq: hwirq=%d, irq=%d\n", hwirq, irq);
    + pr_debug("%s: hwirq=%d, irq=%d\n", __func__, hwirq, irq);

    return irq;
    }
    --
    1.9.1
    \
     
     \ /
      Last update: 2016-10-17 18:54    [W:4.279 / U:0.068 seconds]
    ©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site