lkml.org 
[lkml]   [2016]   [Jan]   [4]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
    /
    Date
    From
    SubjectRe: [PATCH V11 3/7] dma: add Qualcomm Technologies HIDMA management driver
    On Mon, Jan 04, 2016 at 08:37:30PM +0200, Andy Shevchenko wrote:

    > > +static int set_priority(struct hidma_mgmt_dev *mdev, unsigned int i, u64 val)
    > > +{
    > > + u64 tmp;
    > > + int rc;
    > > +
    > > + if (i > mdev->dma_channels)
    >
    > Shouldn't be >= ? I somehow missed that.

    There is no merit is posting not related context while replying, makes your
    emails harder to read, please fix that

    > > + return -EINVAL;
    > > +
    > > + tmp = mdev->priority[i];
    > > + mdev->priority[i] = val;
    > > + rc = hidma_mgmt_setup(mdev);
    > > + if (rc)
    > > + mdev->priority[i] = tmp;
    > > + return rc;
    > > +}
    > > +
    > > +static int set_weight(struct hidma_mgmt_dev *mdev, unsigned int i, u64 val)
    > > +{
    > > + u64 tmp;
    > > + int rc;
    > > +
    > > + if (i > mdev->dma_channels)
    >
    > Ditto.

    Exactly, ditto...


    --
    ~Vinod


    \
     
     \ /
      Last update: 2016-01-05 06:01    [W:2.461 / U:0.020 seconds]
    ©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site