lkml.org 
[lkml]   [2015]   [Sep]   [22]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH] kernel/watchdog: is_hardlockup can be boolean
On Tue 2015-09-22 21:32 +0800, Yaowei Bai wrote:
> This patch makes is_hardlockup return bool to improve readability
> due to this particular function only using either one or zero as its
> return value.
>
> No functional change.
>
> Signed-off-by: Yaowei Bai <bywxiaobai@163.com>
> ---
> kernel/watchdog.c | 6 +++---
> 1 file changed, 3 insertions(+), 3 deletions(-)
>
> diff --git a/kernel/watchdog.c b/kernel/watchdog.c
> index 64ed1c3..568ba64 100644
> --- a/kernel/watchdog.c
> +++ b/kernel/watchdog.c
> @@ -263,15 +263,15 @@ void touch_softlockup_watchdog_sync(void)
>
> #ifdef CONFIG_HARDLOCKUP_DETECTOR
> /* watchdog detector functions */
> -static int is_hardlockup(void)
> +static bool is_hardlockup(void)
> {
> unsigned long hrint = __this_cpu_read(hrtimer_interrupts);
>
> if (__this_cpu_read(hrtimer_interrupts_saved) == hrint)
> - return 1;
> + return true;
>
> __this_cpu_write(hrtimer_interrupts_saved, hrint);
> - return 0;
> + return false;
> }
> #endif
>

Fair enough with regards to readability.

Reviewed-by: Aaron Tomlin <atomlin@redhat.com>
[unhandled content-type:application/pgp-signature]
\
 
 \ /
  Last update: 2015-09-22 16:41    [W:0.071 / U:0.044 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site