lkml.org 
[lkml]   [2015]   [Aug]   [28]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
From
SubjectRe: [PATCH v2 3/3] cpuidle/coupled: Add sanity check for safe_state_index
Date
On Tuesday, August 04, 2015 01:48:57 PM Xunlei Pang wrote:
> From: Xunlei Pang <pang.xunlei@linaro.org>
>
> Since we're using cpuidle_driver::safe_state_index directly as the
> target state index, it's better to add the sanity check at the point
> of registering the driver.
>
> Signed-off-by: Xunlei Pang <pang.xunlei@linaro.org>
> ---
> drivers/cpuidle/driver.c | 13 +++++++++++++
> 1 file changed, 13 insertions(+)
>
> diff --git a/drivers/cpuidle/driver.c b/drivers/cpuidle/driver.c
> index 5db1478..def299e 100644
> --- a/drivers/cpuidle/driver.c
> +++ b/drivers/cpuidle/driver.c
> @@ -223,10 +223,23 @@ static void poll_idle_init(struct cpuidle_driver *drv) {}
> static int __cpuidle_register_driver(struct cpuidle_driver *drv)
> {
> int ret;
> +#ifdef CONFIG_ARCH_NEEDS_CPU_IDLE_COUPLED
> + int i;
> +#endif
>
> if (!drv || !drv->state_count)
> return -EINVAL;
>
> +#ifdef CONFIG_ARCH_NEEDS_CPU_IDLE_COUPLED
> + for (i = drv->state_count - 1; i >= 0; i--) {
> + if (cpuidle_state_is_coupled(drv, i) &&
> + (drv->safe_state_index == i ||
> + drv->safe_state_index < 0 ||
> + drv->safe_state_index >= drv->state_count))
> + return -EINVAL;
> + }
> +#endif

Please move this code to a separate function depending on
CONFIG_ARCH_NEEDS_CPU_IDLE_COUPLED, define a "return 0" stub of it for
CONFIG_ARCH_NEEDS_CPU_IDLE_COUPLED unset and call it from here.

Generally, please try to avoid using #ifdef and similar in function bodies
if possible.

> +
> if (cpuidle_disabled())
> return -ENODEV;
>
>

Thanks,
Rafael



\
 
 \ /
  Last update: 2015-08-28 16:01    [W:1.970 / U:0.004 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site