lkml.org 
[lkml]   [2015]   [Jul]   [6]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
    /
    Date
    From
    SubjectRe: [PATCH] USB-mxuport: Delete an unnecessary check before the function call "release_firmware"
    On Sun, Jun 28, 2015 at 03:09:00PM +0200, SF Markus Elfring wrote:
    > From: Markus Elfring <elfring@users.sourceforge.net>
    > Date: Sun, 28 Jun 2015 14:59:04 +0200
    >
    > The release_firmware() function tests whether its argument is NULL and then
    > returns immediately. Thus the test around the call is not needed.
    >
    > This issue was detected by using the Coccinelle software.
    >
    > Signed-off-by: Markus Elfring <elfring@users.sourceforge.net>
    > ---
    > drivers/usb/serial/mxuport.c | 3 +--
    > 1 file changed, 1 insertion(+), 2 deletions(-)
    >
    > diff --git a/drivers/usb/serial/mxuport.c b/drivers/usb/serial/mxuport.c
    > index 460a406..92f7aee 100644
    > --- a/drivers/usb/serial/mxuport.c
    > +++ b/drivers/usb/serial/mxuport.c
    > @@ -1101,8 +1101,7 @@ static int mxuport_probe(struct usb_serial *serial,
    > */
    > usb_set_serial_data(serial, (void *)id->driver_info);
    > out:
    > - if (fw_p)
    > - release_firmware(fw_p);
    > + release_firmware(fw_p);
    > return err;
    > }

    You sent the exact same patch last year and it was rejected then as it
    does not improve readability:

    https://www.marc.info/?l=linux-usb&m=141682024201419&w=3

    So I'll drop this one again.

    Johan


    \
     
     \ /
      Last update: 2015-07-06 13:01    [W:4.080 / U:0.348 seconds]
    ©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site