lkml.org 
[lkml]   [2015]   [Jul]   [24]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH 1/1] toshiba_acpi: Add set_fan_status function
On Wed, Jul 22, 2015 at 07:37:48PM -0600, Azael Avalos wrote:
> This patch adds a new function named "set_fan_status" to complement
> its get* counterpart, as well as to avoid code duplication between
> "fan_proc_write" and "fan_store".

It also appears to change the error codes returned via sysfs?

Also adds some pr_ statements.

>
> Signed-off-by: Azael Avalos <coproscefalo@gmail.com>
> ---
> drivers/platform/x86/toshiba_acpi.c | 55 ++++++++++++++++++++++++-------------
> 1 file changed, 36 insertions(+), 19 deletions(-)
>
> diff --git a/drivers/platform/x86/toshiba_acpi.c b/drivers/platform/x86/toshiba_acpi.c
> index 6013a11..08fc867 100644
> --- a/drivers/platform/x86/toshiba_acpi.c
> +++ b/drivers/platform/x86/toshiba_acpi.c
> @@ -1422,12 +1422,33 @@ static const struct file_operations video_proc_fops = {
> .write = video_proc_write,
> };
>
> +/* Fan status */
> static int get_fan_status(struct toshiba_acpi_dev *dev, u32 *status)
> {
> - u32 hci_result;
> + u32 result = hci_read(dev, HCI_FAN, status);
>
> - hci_result = hci_read(dev, HCI_FAN, status);
> - return hci_result == TOS_SUCCESS ? 0 : -EIO;
> + if (result == TOS_FAILURE)
> + pr_err("ACPI call to get Fan status failed\n");

s/Fan/fan/

Below too.

> + else if (result == TOS_NOT_SUPPORTED)
> + return -ENODEV;

This condition would have returned -EIO previously correct?

I agree this new one is the right change, but it does pose a risk to userspace.
There is a slim chance we will have to revert if someone complains and can't
work around it, so we need to be clear about this in the commit message at the
very least.
--
Darren Hart
Intel Open Source Technology Center


\
 
 \ /
  Last update: 2015-07-25 01:01    [W:0.103 / U:0.548 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site