lkml.org 
[lkml]   [2015]   [Jul]   [17]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH v2] zsmalloc: do not take class lock in zs_shrinker_count()
Hi,

On (07/18/15 07:42), Minchan Kim wrote:
> I asked to remove the comment of zs_can_compact about lock.
> "Should be called under class->lock."

Oh... I somehow quickly read it and thought you were talking
about the commit message. Fixed and resent.

> Otherwise,
>
> Acked-by: Minchan Kim <minchan@kernel.org>

Thanks.

-ss

> > ---
> > mm/zsmalloc.c | 2 --
> > 1 file changed, 2 deletions(-)
> >
> > diff --git a/mm/zsmalloc.c b/mm/zsmalloc.c
> > index 1edd8a0..ed64cf5 100644
> > --- a/mm/zsmalloc.c
> > +++ b/mm/zsmalloc.c
> > @@ -1836,9 +1836,7 @@ static unsigned long zs_shrinker_count(struct shrinker *shrinker,
> > if (class->index != i)
> > continue;
> >
> > - spin_lock(&class->lock);
> > pages_to_free += zs_can_compact(class);
> > - spin_unlock(&class->lock);
> > }
> >
> > return pages_to_free;
> > --
> > 2.4.6
> >
>
> --
> Kind regards,
> Minchan Kim
>


\
 
 \ /
  Last update: 2015-07-18 03:21    [W:0.045 / U:0.180 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site