lkml.org 
[lkml]   [2015]   [Jul]   [17]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [RFC PATCH 13/21] x86/asm/crypto: Fix frame pointer usage in aesni-intel_asm.S
On Fri, Jul 17, 2015 at 01:46:39PM -0700, Andy Lutomirski wrote:
> On Fri, Jul 17, 2015 at 1:44 PM, Josh Poimboeuf <jpoimboe@redhat.com> wrote:
> > On Fri, Jul 17, 2015 at 01:39:09PM -0700, Andy Lutomirski wrote:
> >> On Fri, Jul 17, 2015 at 1:37 PM, Josh Poimboeuf <jpoimboe@redhat.com> wrote:
> >> > On Fri, Jul 17, 2015 at 12:44:42PM -0700, Andy Lutomirski wrote:
> >> >> On Fri, Jul 17, 2015 at 12:43 PM, Ingo Molnar <mingo@kernel.org> wrote:
> >> >> >
> >> >> > * Josh Poimboeuf <jpoimboe@redhat.com> wrote:
> >> >> >
> >> >> >> ENTRY(aesni_set_key)
> >> >> >> + FRAME
> >> >> >> #ifndef __x86_64__
> >> >> >> pushl KEYP
> >> >> >> movl 8(%esp), KEYP # ctx
> >> >> >> @@ -1905,6 +1907,7 @@ ENTRY(aesni_set_key)
> >> >> >> #ifndef __x86_64__
> >> >> >> popl KEYP
> >> >> >> #endif
> >> >> >> + ENDFRAME
> >> >> >> ret
> >> >> >> ENDPROC(aesni_set_key)
> >> >> >
> >> >> > So cannot we make this a bit more compact and less fragile?
> >> >> >
> >> >> > Instead of:
> >> >> >
> >> >> > ENTRY(aesni_set_key)
> >> >> > FRAME
> >> >> > ...
> >> >> > ENDFRAME
> >> >> > ret
> >> >> > ENDPROC(aesni_set_key)
> >> >> >
> >> >> >
> >> >> > How about writing this as:
> >> >> >
> >> >> > FUNCTION_ENTRY(aesni_set_key)
> >> >> > ...
> >> >> > FUNCTION_RETURN(aesni_set_key)
> >> >> >
> >> >> > which does the same thing in a short, symmetric construct?
> >> >> >
> >> >> > One potential problem with this approach would be that what 'looks' like an entry
> >> >> > declaration, but it will now generate real code.
> >> >> >
> >> >> > OTOH if people find this intuitive enough then it's a lot harder to mess it up,
> >> >> > and I think 'RETURN' makes it clear enough that there's a real instruction
> >> >> > generated there.
> >> >> >
> >> >>
> >> >> How about FUNCTION_PROLOGUE and FUNCTION_EPILOGUE?
> >> >
> >> > Perhaps the macro name should describe what the epilogue does, since
> >> > frame pointers aren't required for _all_ functions, only those which
> >> > don't have call instructions.
> >> >
> >> > What do you think about ENTRY_FRAME and ENDPROC_FRAME_RETURN? The
> >> > ending macro is kind of long, but at least it a) matches the existing
> >> > ENTRY/ENDPROC convention for asm functions; b) gives a clue that frame
> >> > pointers are involved; and c) lets you know that the return is there.
> >> >
> >>
> >> This really is about frame pointers, right? How about
> >> ENTRY_FRAMEPTR_xyz where xyz can be prologue, epilogue, return,
> >> whatever?
> >
> > Wouldn't the "ENTRY" in ENTRY_FRAMEPTR_RETURN be confusing at the end of
> > a function?
>
> I meant ENTRY_FRAMEPTR_xyz and the beginning and ENDPROC_FRAMEPTR_xyz
> (ENTRY is debatable, but that's what we currently have). ENDPROC
> could easily be replaced with anything else.

So do you mean ENTRY_FRAMEPTR_PROLOGUE and ENDPROC_FRAMEPTR_EPILOGUE?
Or something else?

--
Josh


\
 
 \ /
  Last update: 2015-07-17 23:21    [W:0.308 / U:0.032 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site