lkml.org 
[lkml]   [2015]   [Jun]   [3]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
SubjectRe: [PATCH 09/98] via_drm.h: include linux/types.h instead of non-existing via_drmclient.h
From
Hi Mikko,

On 30 May 2015 at 16:38, Mikko Rapeli <mikko.rapeli@iki.fi> wrote:
> Fixes compiler error:
>
> drm/via_drm.h:36:27: fatal error: via_drmclient.h: No such file or directory
>
> Signed-off-by: Mikko Rapeli <mikko.rapeli@iki.fi>
> ---
> include/uapi/drm/via_drm.h | 4 +---
> 1 file changed, 1 insertion(+), 3 deletions(-)
>
> diff --git a/include/uapi/drm/via_drm.h b/include/uapi/drm/via_drm.h
> index 8b0533c..791531e 100644
> --- a/include/uapi/drm/via_drm.h
> +++ b/include/uapi/drm/via_drm.h
> @@ -24,6 +24,7 @@
> #ifndef _VIA_DRM_H_
> #define _VIA_DRM_H_
>
> +#include <linux/types.h>
As mentioned elsewhere one could avoid this, and just use drm.h to
manage the approapriate types (uint32_t vs __u32 and so on).

> #include <drm/drm.h>
>
> /* WARNING: These defines must be the same as what the Xserver uses.
> @@ -33,9 +34,6 @@
> #ifndef _VIA_DEFINES_
> #define _VIA_DEFINES_
>
> -#ifndef __KERNEL__
> -#include "via_drmclient.h"
> -#endif
>
I fear that this one is a particular example of a nasty legacy from
the UMS days. The file is available/provided in very old mesa versions
and at the very same time mesa requires via_drm.h. So I would kindly
ask that you:

- Grab the libdrm userspace package, and apply a similar change.
- Rebuild/install the above.
- Fetch mesa 7.11, and try building the via dri module. Ideally
things will continue to build, alternatively we might need to add
another/additional guard for this include.

Thanks
Emil


\
 
 \ /
  Last update: 2015-06-03 19:41    [W:0.309 / U:0.108 seconds]
©2003-2018 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site