lkml.org 
[lkml]   [2015]   [Jun]   [22]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH] ftrace: correct the counter increment for trace_buffer data
On Mon, 22 Jun 2015 16:55:06 +0530
Umesh Tiwari <umesh.t@samsung.com> wrote:

> In ftrace_dump, for disabling buffer, iter.tr->trace_buffer.data is used.
> But for enabling, iter.trace_buffer->data is used.
> Even though, both point to same buffer, for readability, same convention
> should be used.

Thanks for the two patches. I'm placing these in my todo list, and
hopefully wont forget them. The merge window just opened, which means
I wont get to them until after it closes (probably in two weeks). And
with vacations coming up, it may be later than that.

Feel free to ping me again in three weeks. Even if you don't, I will
eventually get to them, but depending on how much other work piles up,
it could take months.

Sorry about the bad timing here.

-- Steve


>
> Signed-off-by: Umesh Tiwari <umesh.t@samsung.com>
> ---
> kernel/trace/trace.c | 2 +-
> 1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/kernel/trace/trace.c b/kernel/trace/trace.c
> index 62c6506..e6dc9c3 100644
> --- a/kernel/trace/trace.c
> +++ b/kernel/trace/trace.c
> @@ -6698,7 +6698,7 @@ void ftrace_dump(enum ftrace_dump_mode oops_dump_mode)
> trace_init_global_iter(&iter);
>
> for_each_tracing_cpu(cpu) {
> - atomic_inc(&per_cpu_ptr(iter.tr->trace_buffer.data, cpu)->disabled);
> + atomic_inc(&per_cpu_ptr(iter.trace_buffer->data, cpu)->disabled);
> }
>
> old_userobj = trace_flags & TRACE_ITER_SYM_USEROBJ;

--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2015-06-22 16:41    [W:0.034 / U:0.648 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site