lkml.org 
[lkml]   [2015]   [Jun]   [12]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH v8 1/5] drivers: pwm: core: Add pwmchip_add_inversed
On Tue, May 26, 2015 at 01:08:16PM -0700, Jonathan Richardson wrote:
> From: Tim Kryger <tim.kryger@gmail.com>
>
> Add a new function to register a PWM chip with channels that have their
> initial polarity as inversed. This benefits drivers of controllers that
> by default operate with inversed polarity by removing the need to modify
> the polarity during initialization.
>
> Signed-off-by: Tim Kryger <tim.kryger@gmail.com>
> Signed-off-by: Jonathan Richardson <jonathar@broadcom.com>
> ---
> drivers/pwm/core.c | 36 ++++++++++++++++++++++++++++--------
> include/linux/pwm.h | 6 ++++++
> 2 files changed, 34 insertions(+), 8 deletions(-)

I had to bikeshed this a little, so I ended up applying a variant that
exports pwmchip_add_with_polarity() instead of having the additional
wrapper. The rationale here is that pwmchip_add_with_polarity() is more
explicit than pwmchip_add_inversed().

Thierry
[unhandled content-type:application/pgp-signature]
\
 
 \ /
  Last update: 2015-06-12 12:21    [W:0.120 / U:0.068 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site