lkml.org 
[lkml]   [2015]   [May]   [29]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
From
SubjectRe: [PATCH] lsm: rename duplicate labels in LSM_AUDIT_DATA_TASK audit message type
Date
On Wednesday, April 15, 2015 02:08:25 PM Richard Guy Briggs wrote:
> The LSM_AUDIT_DATA_TASK pid= and comm= labels are duplicates of those at the
> start of this function with different values. Rename them to their object
> counterparts opid= and ocomm= to disambiguate.
>
> Signed-off-by: Richard Guy Briggs <rgb@redhat.com>
> ---
> security/lsm_audit.c | 2 +-
> 1 files changed, 1 insertions(+), 1 deletions(-)

Applied, thanks.

> diff --git a/security/lsm_audit.c b/security/lsm_audit.c
> index b526ddc..3323144 100644
> --- a/security/lsm_audit.c
> +++ b/security/lsm_audit.c
> @@ -282,7 +282,7 @@ static void dump_common_audit_data(struct audit_buffer
> *ab, pid_t pid = task_pid_nr(tsk);
> if (pid) {
> char comm[sizeof(tsk->comm)];
> - audit_log_format(ab, " pid=%d comm=", pid);
> + audit_log_format(ab, " opid=%d ocomm=", pid);
> audit_log_untrustedstring(ab,
> memcpy(comm, tsk->comm, sizeof(comm)));
> }

--
paul moore
security @ redhat



\
 
 \ /
  Last update: 2015-05-29 21:41    [W:0.033 / U:14.412 seconds]
©2003-2018 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site