lkml.org 
[lkml]   [2015]   [May]   [29]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH v4 3/17] video: fbdev: gbefb: use arch_phys_wc_add() and devm_ioremap_wc()

* Luis R. Rodriguez <mcgrof@do-not-panic.com> wrote:

> + gbe_mem = devm_ioremap_wc(&p_dev->dev, gbe_mem_phys,
> + gbe_mem_size);

> + gbe_mem = dma_alloc_writecombine(NULL, gbe_mem_size,
> + &gbe_dma_addr, GFP_KERNEL);

> + par->wc_cookie = arch_phys_wc_add(gbe_mem_phys, gbe_mem_size);

> + arch_phys_wc_del(par->wc_cookie);

> + arch_phys_wc_del(par->wc_cookie);

Could we _please_ rename dma_*_writecombine() to dma_*_wc(), so that the naming is
coherent across the various APIs?

Thanks,

Ingo


\
 
 \ /
  Last update: 2015-05-29 09:21    [W:0.070 / U:2.856 seconds]
©2003-2018 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site