lkml.org 
[lkml]   [2015]   [May]   [11]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [Intel-gfx] Commit 0e32b39c ("drm/i915: add DP 1.2 MST support (v0.7)") breaking DP audio on T440s



----- Original Message -----
> From: "Jani Nikula" <jani.nikula@linux.intel.com>
> To: "Paul Moore" <paul@paul-moore.com>, "Dave Airlie" <airlied@redhat.com>, intel-gfx@lists.freedesktop.org
> Cc: "Daniel Gultsch" <daniel@gultsch.de>, linux-kernel@vger.kernel.org
> Sent: Monday, 11 May, 2015 6:01:49 PM
> Subject: Re: [Intel-gfx] Commit 0e32b39c ("drm/i915: add DP 1.2 MST support (v0.7)") breaking DP audio on T440s
>
> On Mon, 11 May 2015, Jani Nikula <jani.nikula@linux.intel.com> wrote:
> > On Fri, 08 May 2015, Paul Moore <paul@paul-moore.com> wrote:
> >> On Fri, Mar 13, 2015 at 11:19 PM, Paul Moore <paul@paul-moore.com> wrote:
> >>> Ever since v3.17 I've had a problem with displayport audio on my
> >>> system, but until lately I haven't had a chance to bisect the problem.
> >>> After a few rounds I've isolated the buggy commit to 0e32b39c
> >>> ("drm/i915: add DP 1.2 MST support (v0.7)").
> >>>
> >>> Simply put, prior to v3.17 everything worked correctly: audio from my
> >>> system was routed to my monitor via the DP connection and finally out
> >>> to the speakers connected to the monitor. However, starting with
> >>> kernel v3.17 this no longer works. The various PulseAudio tools all
> >>> indicate that the HDMI/DP audio output is unplugged/not-available.
> >>> I've tried a few different xrandr commands found via google and
> >>> manpages but nothing short of reverting to v3.16 solves the problem.
> >>> I'm hoping that someone with more understanding of the Intel graphics
> >>> drivers will be able to make some sense of it all and provide a fix.
> >>> I'm more than happy to provide additional information and test any
> >>> patches you may have.
> >>>
> >>> For reference, my system is a ThinkPad T440s with a "Intel Corporation
> >>> Haswell-ULT Integrated Graphics Controller (rev 0b)" (according to
> >>> lspci) connected to a Dell U3011 via a Gefen DP KVM.
> >>
> >> Help?
> >>
> >> The problem still exists on v4.0.1 and I know of at least one other
> >> person that has reported the same problem. As I said above, I'm
> >> willing to do any additional debugging/testing needed, I just could
> >> use some help on resolving this as I am definitely not a
> >> X/graphics-driver expert.
> >
> > Hmm, I never received your first mail.
> >
> > Apparently audio on DP MST is problematic, and the debugging may get a
> > bit involved. Please file a bug at [1] so we don't clutter the lists
> > with logs etc. Please enable drm.debug=14 module parameter and attach
> > (to the bug) dmesg all the way from boot to trying audio on the monitor.
> >
>


I started looking at this today, the audio driver needs serious work to
make this happen, I'm trying to investigate how much work that is.

Dave.


\
 
 \ /
  Last update: 2015-05-11 10:41    [W:0.041 / U:2.384 seconds]
©2003-2018 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site