[lkml]   [2015]   [Apr]   [9]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
SubjectRe: [PATCH 2/2] ide: replace GFP_ATOMIC by GFP_KERNEL
Sorry, my last email was bad.

Splitting patches into logical parts is a bit tricky. Let me try
explain better.

Every patch should sort of make sense on its own. In the original code
it's using GFP_ATOMIC but that's because the original API was bad and
we had no choice. In the 1/1 patch we're using GFP_ATOMIC explicitly
by choice and it's wrong. In patch 2/2 we fix this problem but we
shouldn't introduce bad code even if we fix it in later patches.

dan carpenter

 \ /
  Last update: 2015-04-09 17:21    [W:0.060 / U:1.004 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site