lkml.org 
[lkml]   [2015]   [Apr]   [22]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH v5 00/27] IB/Verbs: IB Management Helpers
On Wed, Apr 22, 2015 at 10:59:52AM -0400, Doug Ledford wrote:
> On Tue, 2015-04-21 at 23:36 +0000, Liran Liss wrote:

[snip]

> >
> > 2)The name rdma_tech_* is lame.
> > rdma_transport_*(), adhering to the above (*) remark, is much better.
> > For example, both IB and ROCE *do* use the same transport.
>
> I especially want to second this. I haven't really been happy with the
> rdma_tech_* names at all.
>

I am sure Michael is open to alternative names. I know I am. The problem is
that we can't figure out what "IBoE" is. It is not a transport, even though
query_transport is now returning it as one. :-P

I think the idea behind the "tech" name was that it is a technology "family".
I can't think of a better name.

Ira



\
 
 \ /
  Last update: 2015-04-22 19:41    [W:2.527 / U:0.004 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site