[lkml]   [2015]   [Apr]   [21]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
SubjectRe: [PATCH v5 19/27] IB/Verbs: Use management helper cap_iw_cm()

On 04/20/2015 05:51 PM, Tom Tucker wrote:
>>>> int ib_query_gid(struct ib_device *device,
>>>> u8 port_num, int index, union ib_gid *gid);
>>> iWARP devices _must_ support the IWCM so cap_iw_cm() is not really useful.
>> Sean suggested to add this helper paired with cap_ib_cm(), may be there are
>> some consideration on maintainability?
>> Me too also prefer this way to make the code more readable ;-)
> It's more consistent, but not necessarily more readable -- if by readability we mean understanding.
> If the reader knows how the transports work, then the reader would be confused by the addition of a check that is always true. For the reader that doesn't know, the addition of the check implies that the support is optional, which it is not.

The purpose is to make sure folks understand what we really want to check
when they reviewing the code :-) and prepared for the further reform which may
not rely on technology type any more, for example the device could tell core
layer directly what management it required with a bitmask :-)

Michael Wang

> Tom
>> Regards,
>> Michael Wang
>> --
>> To unsubscribe from this list: send the line "unsubscribe linux-rdma" in
>> the body of a message to
>> More majordomo info at

 \ /
  Last update: 2015-04-21 10:21    [W:0.149 / U:6.360 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site