lkml.org 
[lkml]   [2015]   [Apr]   [20]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH v5 19/27] IB/Verbs: Use management helper cap_iw_cm()
On Mon, Apr 20, 2015 at 10:51:58AM -0500, Tom Tucker wrote:
> On 4/20/15 10:16 AM, Michael Wang wrote:
> >On 04/20/2015 04:00 PM, Steve Wise wrote:
> >>On 4/20/2015 3:40 AM, Michael Wang wrote:
> >[snip]
> >>>diff --git a/include/rdma/ib_verbs.h b/include/rdma/ib_verbs.h
> >>>index 6805e3e..e4999f6 100644
> >>>+++ b/include/rdma/ib_verbs.h
> >>>@@ -1818,6 +1818,21 @@ static inline int cap_ib_cm(struct ib_device *device, u8 port_num)
> >>> return rdma_ib_or_iboe(device, port_num);
> >>> }
> >>> +/**
> >>>+ * cap_iw_cm - Check if the port of device has the capability IWARP
> >>>+ * Communication Manager.
> >>>+ *
> >>>+ * @device: Device to be checked
> >>>+ * @port_num: Port number of the device
> >>>+ *
> >>>+ * Return 0 when port of the device don't support IWARP
> >>>+ * Communication Manager.
> >>>+ */
> >>>+static inline int cap_iw_cm(struct ib_device *device, u8 port_num)
> >>>+{
> >>>+ return rdma_tech_iwarp(device, port_num);
> >>>+}
> >>>+
> >>> int ib_query_gid(struct ib_device *device,
> >>> u8 port_num, int index, union ib_gid *gid);
> >>iWARP devices _must_ support the IWCM so cap_iw_cm() is not really useful.
> >Sean suggested to add this helper paired with cap_ib_cm(), may be there are
> >some consideration on maintainability?
> >
> >Me too also prefer this way to make the code more readable ;-)
>
> It's more consistent, but not necessarily more readable -- if by
> readability we mean understanding.
>
> If the reader knows how the transports work, then the reader would
> be confused by the addition of a check that is always true. For the
> reader that doesn't know, the addition of the check implies that the
> support is optional, which it is not.

No, it says this code is concerned with the unique parts of iWarp
related to CM, not the other unique parts of iWarp. The check isn't
aways true, it is just always true on iWarp devices.

That became the problem with the old way of just saying 'is iWarp'
(and others). There are too many differences, the why became lost in
many places.

There are now too many standards, and several do not have public docs,
to keep relying on a mess of 'is standard' tests.

Jason


\
 
 \ /
  Last update: 2015-04-20 18:41    [W:0.172 / U:1.616 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site