lkml.org 
[lkml]   [2015]   [Apr]   [17]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: Help with debugging intermittent crash on resume from hibernation
On 03/19/2015 08:57 PM, Mike Galbraith wrote:
> (+CC)
>
> On Thu, 2015-03-19 at 20:21 -0700, Nikolaus Rath wrote:
>> On Mar 13 2015, Nikolaus Rath <Nikolaus@rath.org> wrote:
>>> Hello,
>>>
>>> In about one out of 10 resumes from hibernation, my system resets after
>>> the hibernation image has been loaded. I am hibernating using
>>>
>>> # echo platform > /sys/power/disk
>>> # echo disk > /sys/power/state
>>>
>>> When testing hibernation using
>>>
>>> # echo core > /sys/power/pm_test
>>> # echo platform > /sys/power/disk
>>> # echo disk > /sys/power/state
>>>
>>> I was not able to produce the same failure.
>>>
>>> I then tried attaching a serial console and booted with
>>> console=ttyS0,115200n8 no_console_suspend. For the failed attempt, the
>>> last messages before the reset are:
>> [...]
>>
>> I reproduced the same problem with 4.0.0-rc3. Is there anything I can do
>> to get more debugging information?

I also found that blacklisting the nouveau module seems to dramatically
reduce the occurence of this problem (it only happened once since I
blacklisted the module which is probably about ~30 resumes ago).

Is there anything I can do to help debug this issue?


Best,
-Nikolaus

--
GPG encrypted emails preferred. Key id: 0xD113FCAC3C4E599F
Fingerprint: ED31 791B 2C5C 1613 AF38 8B8A D113 FCAC 3C4E 599F

»Time flies like an arrow, fruit flies like a Banana.«


\
 
 \ /
  Last update: 2015-04-18 05:21    [W:0.072 / U:0.064 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site