lkml.org 
[lkml]   [2015]   [Apr]   [17]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH v1 11/15] serial: imx: initialized DMA w/o HW flow enabled
Hello Sebastian

On 04/13/2015 05:06 PM, Sebastian Andrzej Siewior wrote:
> On Mon, Apr 13, 2015 at 04:40:15PM +0900, jiwang wrote:
>> Hi Sebastian
> Hi Jiada,
>
>>> My question is how was this tested. Before your patch none of my boards
>>> were using DMA because RTS/CTS is not in use and this was a key
>>> requirement. Now SDMA goes crazy. Is there a SDMA firmware required for
>>> this to work?
>> We tested the patch set with our modified kernel tree,
>> and I find upstream kernel is not building SDMA firmware,
>> I will submit another patch to add it.
> Please make sure it is tagged stable. There is no hint that this is required
> and as of it now, it breaks v4.0.
Due to missing of SDMA firmware, uart sdma mode is broken,
but it is uncovered by this commit on your environment.

> One question, where do you have the firmware from? I picked the one from FSL's
> v3.10 SDK and I ended up with FIFO-overflows so it was clearly the wrong one
> (and the built-in SDMA firmware does not work as expected as you mentioned).
I got sdma firmware from FSL kernel tree.
> Is this firmware only required the imx6 series or also for older versions like
> imx5?
the firmware only supports imx6 series, AFAIK,
I checked with Freescale imx6 support team, due to
licensing issue, I am not entitled to upstream FSL SDMA firmware.
so seems currently disable SDMA support for uart is our only option
at the moment.

Thanks,
Jiada
>> Thanks,
>> Jiada
> Sebastian



\
 
 \ /
  Last update: 2015-04-17 11:41    [W:0.361 / U:2.224 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site