lkml.org 
[lkml]   [2015]   [Apr]   [16]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH] ALSA: remove deprecated use of pci api
At Wed, 15 Apr 2015 16:10:17 +0200,
Quentin Lambert wrote:
>
> Replace occurences of the pci api by appropriate call to the dma api.
>
> A simplified version of the semantic patch that finds this problem is as
> follows: (http://coccinelle.lip6.fr)
>
> @deprecated@
> idexpression id;
> position p;
> @@
>
> (
> pci_dma_supported@p ( id, ...)
> |
> pci_alloc_consistent@p ( id, ...)
> )
>
> @bad1@
> idexpression id;
> position deprecated.p;
> @@
> ...when != &id->dev
> when != pci_get_drvdata ( id )
> when != pci_enable_device ( id )
> (
> pci_dma_supported@p ( id, ...)
> |
> pci_alloc_consistent@p ( id, ...)
> )
>
> @depends on !bad1@
> idexpression id;
> expression direction;
> position deprecated.p;
> @@
>
> (
> - pci_dma_supported@p ( id,
> + dma_supported ( &id->dev,
> ...
> + , GFP_ATOMIC
> )
> |
> - pci_alloc_consistent@p ( id,
> + dma_alloc_coherent ( &id->dev,
> ...
> + , GFP_ATOMIC
> )
> )
>
> Signed-off-by: Quentin Lambert <lambert.quentin@gmail.com>

Thanks, applied to for-4.2 branch.


Takashi


\
 
 \ /
  Last update: 2015-04-16 13:01    [W:0.037 / U:3.476 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site