lkml.org 
[lkml]   [2015]   [Apr]   [15]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH 2/5] ufs: Rename of regulator_set_optimum_mode
On Tue 14 Apr 05:11 PDT 2015, Akinobu Mita wrote:

> 2015-02-12 12:35 GMT+09:00 Bjorn Andersson <bjorn.andersson@sonymobile.com>:
> > The function regulator_set_optimum_mode() is changing name to
> > regulator_set_load(), so update the code accordingly. Also cleaned up
> > ufshcd_config_vreg_load() while touching the code.
> >
> > Signed-off-by: Bjorn Andersson <bjorn.andersson@sonymobile.com>

[..]

> > static inline int ufshcd_config_vreg_hpm(struct ufs_hba *hba,
> > struct ufs_vreg *vreg)
> > {
> > - if (!vreg)
> > - return 0;
> > -
> > return ufshcd_config_vreg_load(hba->dev, vreg, vreg->max_uA);
> > }
>
> I tried this patch and it caused kernel null pointer dereference with
> 'verg->max_uA' when vreg == NULL. So you can't simply move !vreg check here
> into ufshcd_config_vreg_load().

Akinobu-san, you're correct, sorry for missing that (and in essence
reverting your commit).

Looks like Linus merged the fix on master, so I will send out a fixup.

Regards,
Bjorn


\
 
 \ /
  Last update: 2015-04-15 20:41    [W:0.079 / U:1.420 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site