[lkml]   [2015]   [Apr]   [13]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
SubjectRe: [RFC] new locking primitive (pulled from fs_pin)
On Mon, Apr 13, 2015 at 12:05 PM, Al Viro <> wrote:
> This thing used to be the locking side of fs/fs_pin.c, but
> IMO it might make sense to separate it from fs_pin completely -
> it could be useful elsewhere...
> Comments (and especially suggestions on better names) are welcome...

I don't mind abstracting it out, but I would prefer that it stay local
to fs_pin.c until there's a clear case for using it anywhere else.

Do you really have any usage cases that are interesting? Because quite
frankly, I'm not a fan of the nasty fs-pin code, and I would *not*
want the ideas in there to bleed out anywhere else.

So my gut feel is that it's a good thing to try to abstract out that
mess, but not a good idea to spread it out.

(I do realize that without the cross-file movement, the patch
basically just boils down to abstracting out that "finished_killing()"
into a helper function and little else)


 \ /
  Last update: 2015-04-14 00:01    [W:0.035 / U:2.904 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site