lkml.org 
[lkml]   [2015]   [Apr]   [13]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
From
SubjectRE: [PATCH v3 04/28] IB/Verbs: Reform IB-core cm
Date
> > -	if (rdma_node_get_transport(ib_device->node_type) !=
> RDMA_TRANSPORT_IB)
> > - return;
> > + int count = 0;
>
> I'm ok with this as an intermediate patch but going forward if we are
> going to
> have calls like
>
> static inline int cap_ib_cm_dev(struct ib_device *device)

I would rather keep everything to checking per port, not per device. Specifically, because we have code that does this:

> > port = kzalloc(sizeof *port, GFP_KERNEL);
> > if (!port)
> > goto error1;
> > @@ -3809,7 +3810,16 @@ static void cm_add_one(struct ib_device
> *ib_device)
> > ret = ib_modify_port(ib_device, i, 0, &port_modify);
> > if (ret)
> > goto error3;

It will also help keep the checks consistent, so that we don't end up with CM checks being per device, but SA checks being per port.

- Sean


\
 
 \ /
  Last update: 2015-04-13 21:21    [W:0.133 / U:0.504 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site