lkml.org 
[lkml]   [2015]   [Apr]   [10]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
Subject[next:master 9498/10844] drivers/input/mouse/alps.c:1096:15: sparse: symbol 'alps_get_pkt_id_ss4_v2' was not declared. Should it be static?
tree:   git://git.kernel.org/pub/scm/linux/kernel/git/next/linux-next.git master
head: ab738b3efaea11cf9f130c7fe9ebb7568e998fe6
commit: 3db5b9f782b50a309fe0fb89fb890f6b4f66d9ae [9498/10844] Input: ALPS - add support for SS4 touchpad devices
reproduce:
# apt-get install sparse
git checkout 3db5b9f782b50a309fe0fb89fb890f6b4f66d9ae
make ARCH=x86_64 allmodconfig
make C=1 CF=-D__CHECK_ENDIAN__


sparse warnings: (new ones prefixed by >>)

>> drivers/input/mouse/alps.c:1096:15: sparse: symbol 'alps_get_pkt_id_ss4_v2' was not declared. Should it be static?
>> drivers/input/mouse/alps.c:2343:5: sparse: symbol 'alps_update_device_area_ss4_v2' was not declared. Should it be static?
>> drivers/input/mouse/alps.c:2368:5: sparse: symbol 'alps_update_btn_info_ss4_v2' was not declared. Should it be static?

Please review and possibly fold the followup patch.

---
0-DAY kernel test infrastructure Open Source Technology Center
http://lists.01.org/mailman/listinfo/kbuild Intel Corporation


\
 
 \ /
  Last update: 2015-04-11 04:01    [W:0.373 / U:0.104 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site