lkml.org 
[lkml]   [2015]   [Mar]   [9]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
From
SubjectRe: [PATCH] of: Kconfig: Let OF_UNITTEST depend on "I2C=y" and "I2C_MUX=y"
Date
On Thursday 05 March 2015 09:06:54 Geert Uytterhoeven wrote:
> On Wed, Mar 4, 2015 at 8:49 PM, Arnd Bergmann <arnd@arndb.de> wrote:
> > --- a/drivers/of/unittest.c
> > +++ b/drivers/of/unittest.c
> > @@ -979,7 +979,7 @@ static int of_path_platform_device_exists(const char *path)
> > return pdev != NULL;
> > }
> >
> > -#if IS_ENABLED(CONFIG_I2C)
> > +#if IS_BUILTIN(CONFIG_I2C)
>
> Wondering: is there any advantage in using "#if IS_BUILTIN(CONFIG_XXX)"
> instead of "#ifdef CONFIG_XXX"?

Mostly consistency within the file.

There are also lines like

#if IS_BUILTIN(CONFIG_I2C) && IS_ENABLED(CONFIG_OF_OVERLAY)

which I find more readable than mixing the two styles as in

#if defined(CONFIG_I2C) && IS_ENABLED(CONFIG_OF_OVERLAY)

Arnd


\
 
 \ /
  Last update: 2015-03-09 22:41    [W:0.088 / U:0.272 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site