lkml.org 
[lkml]   [2015]   [Mar]   [6]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH v2 6/6] x86, asm: Rename INIT_TSS_IST to TSS_IST

* Andy Lutomirski <luto@amacapital.net> wrote:

> This has nothing to do with the init thread or the initial anything.
> It's just the TSS.
>
> Signed-off-by: Andy Lutomirski <luto@amacapital.net>
> ---
> arch/x86/kernel/entry_64.S | 6 +++---
> 1 file changed, 3 insertions(+), 3 deletions(-)
>
> diff --git a/arch/x86/kernel/entry_64.S b/arch/x86/kernel/entry_64.S
> index 0c00fd80249a..c86f83e95f15 100644
> --- a/arch/x86/kernel/entry_64.S
> +++ b/arch/x86/kernel/entry_64.S
> @@ -959,7 +959,7 @@ apicinterrupt IRQ_WORK_VECTOR \
> /*
> * Exception entry points.
> */
> -#define INIT_TSS_IST(x) PER_CPU_VAR(cpu_tss) + (TSS_ist + ((x) - 1) * 8)
> +#define TSS_IST(x) PER_CPU_VAR(cpu_tss) + (TSS_ist + ((x) - 1) * 8)
>
> .macro idtentry sym do_sym has_error_code:req paranoid=0 shift_ist=-1
> ENTRY(\sym)
> @@ -1015,13 +1015,13 @@ ENTRY(\sym)
> .endif
>
> .if \shift_ist != -1
> - subq $EXCEPTION_STKSZ, INIT_TSS_IST(\shift_ist)
> + subq $EXCEPTION_STKSZ, TSS_IST(\shift_ist)
> .endif
>
> call \do_sym
>
> .if \shift_ist != -1
> - addq $EXCEPTION_STKSZ, INIT_TSS_IST(\shift_ist)
> + addq $EXCEPTION_STKSZ, TSS_IST(\shift_ist)
> .endif
>
> /* these procedures expect "no swapgs" flag in ebx */

If you don't mind I've renamed this to 'CPU_TSS_IST', to be in line
with cpu_tss.

The per-cpuness of this symbol gets lost at the usage sites, because
the PER_CPU_VAR() reference is hidden in a macro.

Thanks,

Ingo


\
 
 \ /
  Last update: 2015-03-06 08:41    [W:0.477 / U:0.336 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site