lkml.org 
[lkml]   [2015]   [Mar]   [4]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
    /
    SubjectRe: [Gta04-owner] [PATCH 3/4] usb: phy: twl4030: add support for reading restore on ID pin.
    From
    Date

    Am 04.03.2015 um 07:35 schrieb NeilBrown <neilb@suse.de>:

    > On Mon, 2 Mar 2015 22:04:31 +0100 Pavel Machek <pavel@ucw.cz> wrote:
    >
    >> Hi!
    >>
    >>> The twl4030 phy can measure, with low precision, the
    >>> resistance-to-ground of the ID pin.
    >>>
    >>> Add a function to read the value, and export the result
    >>> via sysfs.
    >>>
    >>> If the read fails, which it does sometimes, try again in 50msec.
    >>>
    >>> Signed-off-by: NeilBrown <neilb@suse.de>
    >>> ---
    >>> drivers/phy/phy-twl4030-usb.c | 63 +++++++++++++++++++++++++++++++++++++++++
    >>> 1 file changed, 63 insertions(+)
    >>>
    >>> diff --git a/drivers/phy/phy-twl4030-usb.c b/drivers/phy/phy-twl4030-usb.c
    >>> index 023fe150c7a1..759950898df9 100644
    >>> --- a/drivers/phy/phy-twl4030-usb.c
    >>> +++ b/drivers/phy/phy-twl4030-usb.c
    >>> @@ -374,6 +374,56 @@ static void twl4030_i2c_access(struct twl4030_usb *twl, int on)
    >>> }
    >>> }
    >>>
    >>> +enum twl4030_id_status {
    >>> + TWL4030_GROUND,
    >>> + TWL4030_102K,
    >>> + TWL4030_200K,
    >>> + TWL4030_440K,
    >>> + TWL4030_FLOATING,
    >>> + TWL4030_ID_UNKNOWN,
    >>> +};
    >>> +static char *twl4030_id_names[] = {
    >>> + "ground",
    >>> + "102k",
    >>> + "200k",
    >>> + "440k",
    >>
    >> New /sys files should be documented somewhere...?
    >
    > Preferably with the code...
    >
    >>
    >> Does it make sense to change "440k" -> "440KOhm"?
    >
    > Interesting question. I prefer to avoid including units in files - bare
    > numbers is better. But there is no number to match "floating" unless I spell
    > it out as "infinity", and wouldn't be helpful.
    >
    > Certainly "K" would be preferred over "k“,

    The international standard for kilo = 1000 is a lower case k.
    While it is (non-standard) to use K for 1024:

    http://en.wikipedia.org/wiki/Kilobyte

    So I would keep the string constants lower case to avoid this potential confusion.

    > and given that I have "ground"
    > and "floating", it is more consistent to include the "Ohm"....
    >
    > These are really names, not measures of resistance. The data sheet calls
    > them:
    > ID_RES_FLOAT (or sometimes ID_FLOAT)
    > ID_RES_440K
    > ID_RES_200K
    > ID_RES_102K
    > ID_GND (or sometimes ID_RES_GND)
    >
    > So using those names is defensible.
    >
    > I think I'll change them all to upper case, but leave out the "Ohm".
    > My justification is consistency with the data sheet.
    >
    >
    >
    >
    >>
    >> Plus I guess you need to update Documentation/
    >
    > I guess I'll need to give in to this eventually :-)
    >
    >>
    >> Acked-by: Pavel Machek <pavel@ucw.cz>
    >>
    >
    > Thanks,
    > NeilBrown
    > _______________________________________________
    > Gta04-owner mailing list
    > Gta04-owner@goldelico.com
    > http://lists.goldelico.com/mailman/listinfo.cgi/gta04-owner



    \
     
     \ /
      Last update: 2015-03-04 08:21    [W:7.718 / U:0.012 seconds]
    ©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site