lkml.org 
[lkml]   [2015]   [Feb]   [11]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH 2/4] mm: rename __mlock_vma_pages_range() to populate_vma_page_range()
On Wed, 11 Feb 2015, Kirill A. Shutemov wrote:

> __mlock_vma_pages_range() doesn't necessary mlock pages. It depends on
> vma flags. The same codepath is used for MAP_POPULATE.
>

s/necessary/necessarily/

> Let's rename __mlock_vma_pages_range() to populate_vma_page_range().
>
> This patch also drops mlock_vma_pages_range() references from
> documentation. It has gone in commit cea10a19b797.
>
> Signed-off-by: Kirill A. Shutemov <kirill.shutemov@linux.intel.com>

I think it makes sense to drop the references about "downgrading"
mm->mmap_sem in the documentation since populate_vma_page_range() can be
called with it held either for read or write depending on the context.

Acked-by: David Rientjes <rientjes@google.com>


\
 
 \ /
  Last update: 2015-02-11 21:21    [W:0.075 / U:1.848 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site