lkml.org 
[lkml]   [2015]   [Feb]   [11]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
From
Subject[PATCH 0/4] Cleanup mm_populate() codepath
Date
While reading mlock()- and mm_populate()-related code, I've found several
things confusing. This patchset cleanup the codepath for future readers.

Kirill A. Shutemov (4):
mm: rename FOLL_MLOCK to FOLL_POPULATE
mm: rename __mlock_vma_pages_range() to populate_vma_page_range()
mm: move gup() -> posix mlock() error conversion out of __mm_populate
mm: move mm_populate()-related code to mm/gup.c

Documentation/vm/unevictable-lru.txt | 26 +++----
include/linux/mm.h | 2 +-
mm/gup.c | 124 ++++++++++++++++++++++++++++++++-
mm/huge_memory.c | 2 +-
mm/internal.h | 2 +-
mm/mlock.c | 131 +++--------------------------------
mm/mmap.c | 4 +-
7 files changed, 142 insertions(+), 149 deletions(-)

--
2.1.4



\
 
 \ /
  Last update: 2015-02-11 18:21    [W:0.781 / U:0.008 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site