lkml.org 
[lkml]   [2015]   [Dec]   [4]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [RFC PATCH 76/71] ncr5380: Enable PDMA for DTC chips

On Fri, 4 Dec 2015, Julian Calaby wrote:

> > - if (overrides[current_override].board == BOARD_NCR53C400A) {
> > + if (overrides[current_override].board == BOARD_NCR53C400A ||
> > + overrides[current_override].board == BOARD_DTC3181E) {
>
> These if statements are starting to get a bit long, would it make
> sense to replace them with a flag or equivalent?

To what end? Shorter lines? As in,

if (board_is_ncr53c400a || board_is_dtc3181e) {
/* ... */
}

I suppose that could be an improvement if new flags would entirely replace
the override.board struct member and the existing switch statement,

switch (overrides[current_override].board) {
/* ... */
}

Or maybe you meant testing a new flag something like this,

if (hostdata->ncr53c400_compatible) {
/* ... */
}

If your concern is the Don't Repeat Yourself rule, I'm not sure that new
flag would get tested more than once (?) And it would still have to be
assigned using an "objectionably" long expression, e.g.

hostdata->ncr53c400_compatible =
overrides[current_override].board == BOARD_NCR53C400 ||
overrides[current_override].board == BOARD_NCR53C400A ||
overrides[current_override].board == BOARD_DTC3181E;

Rather than add new flags, perhaps a 'switch' statement instead of an 'if'
statement would be shorter (if the size of the expression is the problem).

--


\
 
 \ /
  Last update: 2015-12-04 10:01    [W:0.151 / U:0.208 seconds]
©2003-2018 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site