lkml.org 
[lkml]   [2015]   [Dec]   [3]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
SubjectRe: [PATCH] sched/core: Clear the root_domain cpumasks in init_rootdomain()
From
Date
Hi Ingo,

On 12/03/2015 at 04:28 PM, Ingo Molnar wrote:
> * Xunlei Pang <xlpang@redhat.com> wrote:
>
>> Hi Peter,
>>
>> On 12/03/2015 at 12:25 AM, Peter Zijlstra wrote:
>>> On Wed, Dec 02, 2015 at 09:12:30PM +0800, Xunlei Pang wrote:
>>>> Hi Peter,
>>>>
>>>> On 12/02/2015 at 08:34 PM, Peter Zijlstra wrote:
>>>>> On Wed, Dec 02, 2015 at 07:52:59PM +0800, Xunlei Pang wrote:
>>>>>> The patch cleans the garbage by using zalloc_cpumask_var()
>>>>>> instead of alloc_cpumask_var() for root_domain::rto_mask
>>>>>> allocation, thereby addressing the issues.
>>>>> How did you notice this? Also do we want to do the same for the kmalloc
>>>> When doing review.
>>> Nice, will you be looking for similar issues elsewhere in the scheduler
>>> too?
>> Sure :-)
> Hm, is the alloc_cpumask_var() done in alloc_sched_domains() safe?

Until now, I haven't found any other similar issues, but I will check further.

>
> At least the usage pattern in init_sched_domains() looks unsafe:
>
> doms_cur = alloc_sched_domains(ndoms_cur);
> if (!doms_cur)
> doms_cur = &fallback_doms;
> cpumask_andnot(doms_cur[0], cpu_map, cpu_isolated_map);
>
> I think alloc_cpumask_var() is a fundamentally unsafe or at least fragile
> operation, because the uninitialized variable bug will only happen on large CPU
> count kernels AFAICS - so it's inviting such bugs.
>
> How about we rename alloc_cpumask_var() to alloc_cpumask_var_noinit() or at least
> __alloc_cpumask_var(), to make this property easier to see?

There have already been many call sites of it in the kernel, at least we still
have zalloc_cpumask_var(), maybe we could add some function comments,
reminding people of thinking of zalloc_cpumask_var() for their cases.

Regards,
Xunlei

>
> Thanks,
>
> Ingo



\
 
 \ /
  Last update: 2015-12-03 13:01    [W:0.083 / U:0.104 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site