lkml.org 
[lkml]   [2015]   [Nov]   [16]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
From
Subject[PATCH 0/7] some small improvement
Date
This patchset only performs some small improvement to mm. First, make
several functions return bool to improve readability, and then remove
unused is_unevictable_lru function and refactor memmap_valid_within
for simplicity.

No functional change.

Yaowei Bai (7):
ipc/shm: is_file_shm_hugepages can be boolean
mm/hugetlb: is_file_hugepages can be boolean
mm/memblock: memblock_is_memory/reserved can be boolean
mm/vmscan: page_is_file_cache can be boolean
mm/lru: remove unused is_unevictable_lru function
mm/gfp: make gfp_zonelist return directly and bool
mm/mmzone: refactor memmap_valid_within

include/linux/gfp.h | 7 ++-----
include/linux/hugetlb.h | 10 ++++------
include/linux/memblock.h | 4 ++--
include/linux/mm_inline.h | 6 +++---
include/linux/mmzone.h | 11 +++--------
include/linux/shm.h | 6 +++---
ipc/shm.c | 2 +-
mm/memblock.c | 4 ++--
mm/mmzone.c | 10 ++--------
9 files changed, 22 insertions(+), 38 deletions(-)

--
1.9.1





\
 
 \ /
  Last update: 2015-11-16 08:01    [W:1.607 / U:0.076 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site