lkml.org 
[lkml]   [2015]   [Oct]   [5]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
SubjectRe: [PATCH 8/8] bdc_pci: use PCI_VDEVICE() instead of PCI_DEVICE()
From
Date
Hello.

On 10/5/2015 6:16 AM, Greg KH wrote:

>> Fix using the PCI_DEVICE() macro instead of less verbose PCI_VDEVICE().

> Why?

Seemed a good idea to me back in March. :-)

> I hate PCI_VDEVICE(), it's impossible to grep for things and does

Didn't think about grepping...

> not help with readability and is pointless. My one wish was that when I
> was the PCI maintainer I would have just deleted the thing from the
> kernel entirely instead of leaving it there hoping no one would use it.

Thanks for the idea. :-)

> I don't like these types of pointless patches, sorry.

I hope you don't have the same strong feelings about PCI_DEVICE_SUB().
There's one place (in ohci-pci.c IIRC) it can be used...

> thanks,
>
> greg k-h

MBR, Sergei



\
 
 \ /
  Last update: 2015-10-05 15:41    [from the cache]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and my Meterkast|Read the blog