lkml.org 
[lkml]   [2015]   [Oct]   [5]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
SubjectRe: [PATCH v2 05/14] RDS: defer the over_batch work to send worker
From
From: Santosh Shilimkar <santosh.shilimkar@oracle.com>
Date: Wed, 30 Sep 2015 13:24:24 -0400

> @@ -423,7 +423,9 @@ over_batch:
> !list_empty(&conn->c_send_queue)) &&
> send_gen == conn->c_send_gen) {
> rds_stats_inc(s_send_lock_queue_raced);
> - goto restart;
> + if (batch_count < 1024)
> + goto restart;
> + queue_delayed_work(rds_wq, &conn->c_send_w, 1);

Sorry, you can't just use a magic number like this.

You have to describe, in detail, exactly how this value was
choosen, derived, and tested to be effeective and in exactly
what environment those tests were done.

You must also use a mnenomic for this value rather than a
raw magic constant.

Thanks.


\
 
 \ /
  Last update: 2015-10-05 12:41    [W:1.637 / U:0.144 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site