lkml.org 
[lkml]   [2015]   [Oct]   [3]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
SubjectRe: [PATCH 3/24] ver_linux: gcc.patch
From
On Sat, Oct 3, 2015 at 3:07 PM, Alexander Kapshuk
<alexander.kapshuk@gmail.com> wrote:
> Using 'awk' here is a bit of an overkill. Should the output of 'gcc
> -dumpversion' vary on another disto, or change overtime, it may no longer
> be available at field 1, as relied on by the current implementation.
> I believe 'sed' offers greater flexibility here in terms of processing
> varying output as well as being more light-weight.
>
> Tested on:
> Gentoo Linux
> Debian 6.0.10
> Oracle Linux Server release 7.1
> Arch Linux
> openSuSE 13.2
>
> Signed-off-by: Alexander Kapshuk <alexander.kapshuk@gmail.com>
> ---
> --- linux/scripts/ver_linux.orig 2015-10-03 13:41:57.118790241 +0300
> +++ linux/scripts/ver_linux 2015-10-03 13:48:49.277622632 +0300
> @@ -11,8 +11,12 @@
> uname -a
> echo ' '
>
> -gcc -dumpversion 2>&1| awk \
> -'NR==1{print "Gnu C ", $1}'
> +test -x "$gcc" &&
> +$gcc -dumpversion 2>&1 |
> +sed '
> + /^[0-9\.]*$/!d
> + s/^/GNU C\t\t\t/
> +'

I'm not sure whether replacing a bog standard idiom with a non-trivial
sed expression
is a good idea.
Your argument that currently the version has to be the first field is weak,
your script has a even stronger assumption, it assumes that the
version is field 1
_and_ has too be numeric.
But maybe I'm misinterpreting your regex, regex is hard to read for a human. :)

IMHO we should keep things simple. It's not that ver_linux (and other
scripts you patch) are hot paths
in the kernel build process.

--
Thanks,
//richard


\
 
 \ /
  Last update: 2015-10-03 17:21    [from the cache]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and my Meterkast|Read the blog