[lkml]   [2015]   [Jan]   [30]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
SubjectRe: [PATCH 1/3 V3] acpi:soc: merge common codes for creating platform device
On Friday, January 30, 2015 07:07:14 AM Xue, Ken wrote:
> Hi Rafael,
> I looked into your patch in
> I found that "XXX_platform_notify" should be implemented separately in LPSS and APD driver instead of "acpi_soc_platform_notify" in acpi_soc.
> Because there is WA can't be share with two drivers. And it can make LPSS or APD driver more flexible.
> Then only "acpi_soc_create_device" can be shared by LPSS and APD. Maybe, the meaning of acpi_soc becomes less than what we expected.
> So, can we go back to two separated drivers without any binding?

I don't want code duplication between them, though. So if there's a function
that may be shared between them, it should be shared. And so on. No duplicate
data structure definitions etc.

> And try thoughts about acpi_soc, if there were more common features.

As I said. If you can do that without code duplication, please feel free to try.

I speak only for myself.
Rafael J. Wysocki, Intel Open Source Technology Center.

 \ /
  Last update: 2015-01-30 16:01    [W:0.051 / U:3.112 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site