[lkml]   [2015]   [Jan]   [19]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
SubjectRe: [PATCH v2 1/3] Drivers: hv: check vmbus_device_create() return value in vmbus_process_offer()
On Mon, Jan 19, 2015 at 05:56:11PM +0100, Vitaly Kuznetsov wrote:
> vmbus_device_create() result is not being checked in vmbus_process_offer() and
> it can fail if kzalloc() fails. Add the check and do minor cleanup to avoid
> additional duplication of "free_channel(); return;" block.
> Reported-by: Jason Wang <>
> Signed-off-by: Vitaly Kuznetsov <>

"out" is always a bad name for a label. It's too vague. It implies
that the code uses "One Err" style error handling which is bug prone and
I've ranted about that in the past so I won't here. This kind of coding
is buggier than direct returns. But recently I've been looking at bugs
where we return zero where the code should return a negative error code
and, wow, do I hate "out" labels!

if (function_whatever(xxx))
goto out;

[ thousands of lines removed. ]

return ret;

Oh crap... Did the coder mean to return success or not???

If you use a direct return then the code looks like:

if (function_whatever(xxx))
return 0;

In that case, you can immediately see that the coder typed "0"
deliberately. Direct returns are best. I guess that's not directly
related to this code. But I didn't know that until I read to the bottom
of the patch and I already had this rant prepared in my head ready to

"error" is a crap label name because it doesn't tell you what the code
does. A better name is "err_free_chan" or something which talks about
freeing the channel.

dan carpenter

 \ /
  Last update: 2015-01-19 19:21    [W:0.071 / U:0.816 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site