lkml.org 
[lkml]   [2014]   [Jul]   [3]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH V4 02/16] perf, core: introduce pmu context switch callback
On 07/02/2014 06:12 PM, Peter Zijlstra wrote:
> On Mon, Jun 30, 2014 at 04:50:39PM +0800, Yan, Zheng wrote:
>> @@ -2362,6 +2363,58 @@ unlock:
>> }
>> }
>>
>> +void perf_sched_cb_disable(struct pmu *pmu)
>> +{
>> + __get_cpu_var(perf_sched_cb_usages)--;
>> +}
>> +
>> +void perf_sched_cb_enable(struct pmu *pmu)
>> +{
>> + __get_cpu_var(perf_sched_cb_usages)++;
>> +}
>
> Those should not be called {dis,en}able, they don't as such do that.

I can't think up a better name. what should they be called?

Regards
Yan, Zheng

> Also we have: this_cpu_{inc,dec} for this.
>



\
 
 \ /
  Last update: 2014-07-03 08:21    [W:0.066 / U:1.880 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site