[lkml]   [2014]   [Jul]   [24]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
SubjectRe: [PATCH 00/15] atmel_mxt_ts - device tree, bootloader, etc
On 23/07/14 18:22, Stephen Warren wrote:
> That didn't make any difference.
> I also tried the tool interactively. the "Display raw (M)essages" option
> never displayed anything, and the couple of self-tests I tried just
> timed out. "Read (I)nfo block" did display some values that seemed like
> they might be correct rather than random data.
> Interestingly though, I did bisect the series and found "Input:
> atmel_mxt_ts - use deep sleep mode when stopped" causes the problem. If
> I apply the whole series and revert that one patch, the touchpad works
> for mouse movement, but interestingly not for taps or physical clicks.

Could you dump out the config for me (when it's in the failed state)? This
can be done by running:

mxt-app [device] --save fail.xcfg

>> FWIW, this warning generally means you should be using the CHG line mode 1
>> in T18 COMMSCONFIG. It's benign, though.
> I'm not sure how I would adjust this; all firmware/config/... was
> flashed into the touchpad device itself before I received the system,
> and I don't have any firmware files on my host system.

It can be done via mxt-app. I would probably keep a known good config (via
--save/--load) if you're going to start making changes, though. Something like:

Write correct COMMSCONFIG settings:
mxt-app [device] -W -T18 44

Backup config to NVRAM:
mxt-app [device] --backup

I have on my TODO list to make the driver adjust this automatically.

 \ /
  Last update: 2014-07-24 16:22    [W:0.106 / U:3.232 seconds]
©2003-2018 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site