[lkml]   [2014]   [Jul]   [24]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
SubjectRe: [PATCH 27/28] phy: miphy365x: Provide support for the MiPHY356x Generic PHY
On Tue, 2014-07-22 at 16:26 +0530, Kishon Vijay Abraham I wrote:
> From: Lee Jones <>
> The MiPHY365x is a Generic PHY which can serve various SATA or PCIe
> devices. It has 2 ports which it can use for either; both SATA, both
> PCIe or one of each in any configuration.
> Acked-by: Mark Rutland <>
> Signed-off-by: Alexandre Torgue <>
> Signed-off-by: Lee Jones <>
> Signed-off-by: Kishon Vijay Abraham I <>
> ---

This patch landed in today's linux-next (ie, next-20140724).

> --- /dev/null
> +++ b/drivers/phy/phy-miphy365x.c
> @@ -0,0 +1,616 @@
> +
> +#define PLL_CTRL1_REG 0x50
> +#define PLL_START_CAL BIT(0)
> +#define BUF_EN BIT(2)
> +#define SYNCHRO_TX BIT(3)
> +#define SSC_EN BIT(6)
> +#define CONFIG_PLL BIT(7)

This is probably a pet peeve very few people share, but anyway: would it
be possible to not use the CONFIG_ prefix here? Ie, to use, say, CONF_
or CFG_ instead.

I know there are quite a few preprocessor defines for macros starting
with CONFIG_ already. And I realize CONFIG_ is rather generic. But that
is what the build system uses so I do think it would preferable to try
to use it only for actual Kconfig macros.

Paul Bolle

 \ /
  Last update: 2014-07-24 13:21    [W:0.140 / U:0.440 seconds]
©2003-2018 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site