lkml.org 
[lkml]   [2014]   [Jul]   [13]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
From
Subject[PATCH v4 0/4] Add support for Lenovo Compact Keyboard
Date
This patchset follows on from my previous attempts to add support for
these keyboards from Lenovo.

Changes since v3: https://lkml.org/lkml/2014/6/15/159
* Break up first patch [Antonio Ospite]
* Rename ABI docs too [Jiri Kosina]
* Spelling and Grammar, style fixes [Antonio Ospite]
* Driver should just be called 'lenovo' [Antonio Ospite]
* Remove useless id from probe functions [Antonio Ospite]
* Use KEY_SCALE to match Thinkpad ??40 models [Hans de Goede]
* Add ABI documentation for fn_lock setting [Jiri Kosina]
* Use a bool for fn_lock instead of uint [Antonio Ospite]
* hid_output_raw_report has been replaced with hid_hw_raw_request [Antonio Ospite]

Changes since v2: https://lkml.org/lkml/2014/6/10/730
* Rename hid-lenovo-tpkbd to hid-lenovo, to make it obvious this is
for any Lenovo-manufactured device [Antonio Ospite, Jiri Kosina]
* Style fixes: function calls in conditions, combine checks for
both USB & BT keyboards [Antonio Ospite]

Changes since v1: https://lkml.org/lkml/2014/3/25/535
* Merge driver into hid-lenovo-tpkbd.c instead of creating our own
driver for the hardware [Jiri Kosina]
* Remove key mappings which are now supported by standard
* Use KEY_FILE for Fn-F12 (opens My Computer on Windows)
* Support the USB variant as well as Bluetooth
* Expose the Fn Lock setting as a sysfs attribute instead of trying to
build a mechanism to toggle into the kernel

Applies against v3.16-rc4, tested with Bluetooth and USB variants of the
Compact Keyboard with Trackpoint.

Cheers,

Jamie Lentin (4):
Rename hid-lenovo-tpkbd to hid-lenovo
Make all base functions switch depending on product ID
Style fixes
Add support for Compact (Bluetooth|USB) keyboard with Trackpoint

...er-hid-lenovo-tpkbd => sysfs-driver-hid-lenovo} | 12 +
drivers/hid/Kconfig | 16 +-
drivers/hid/Makefile | 2 +-
drivers/hid/hid-core.c | 4 +-
drivers/hid/hid-ids.h | 2 +
drivers/hid/hid-lenovo-tpkbd.c | 462 --------------
drivers/hid/hid-lenovo.c | 696 +++++++++++++++++++++
include/linux/hid.h | 1 +
8 files changed, 724 insertions(+), 471 deletions(-)
rename Documentation/ABI/testing/{sysfs-driver-hid-lenovo-tpkbd => sysfs-driver-hid-lenovo} (75%)
delete mode 100644 drivers/hid/hid-lenovo-tpkbd.c
create mode 100644 drivers/hid/hid-lenovo.c

--
2.0.0



\
 
 \ /
  Last update: 2014-07-13 10:01    [W:0.207 / U:0.064 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site