lkml.org 
[lkml]   [2014]   [Jul]   [11]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
From
Subject[PATCHv8 0/2] Common Mailbox Framework
Date
Hello,
Here is the next revision of Mailbox framwork.

Changes since v7:
o Added documentation and example usage.
o Merged all patches into one that create api, bindings and
documentation.

Changes since v6:
o Separate out generic DT bindings patch.
o Discard unnecessary aligned attributes.

Changes since v5:
o Use standard error types instead of special type mbox_result.
o Constify client struct in request_channel
o Use reinit_completion instead of init_completion every time.
o Improve commentary in bindings and code.

Changes since v4:
o Common DT binding for Controller and Client drivers
As a result, discard string based channel matching
o Provide for an atomic 'peek' api, that a client could
call to trigger the controller driver push data upwards.
o OMAP and Highbank conversion to new api is left out, which
can be converted later by the developers.

Changes since v3:
o Change name of symbols from ipc to mbox
o Return real types instead of void *
o Align structures
o Change some symbol names
rxcb -> rx_callback
txcb -> tx_done
o Added kernel-doc for exported API
o Dropped the cl_id and use clients pointer for callbacks.
o Fixed locking of channel pool
o Return negative error code for unsuccessful ipc_send_message()
o Module referencing during mailbox assignment to a client.
o Made error code symbols specific to mailbox.

Thanks
Jassi


\
 
 \ /
  Last update: 2014-07-11 12:41    [W:0.103 / U:1.476 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site